Client certificates issued by StartCom Class 1 Client CA not trusted/ working with Apple IOS 10

This forum is dedicated to everything related to the StartCom Certification Authority, including installation issues and questions surrounding Client Certificate.
florian@figula.de
Posts: 1
Joined: Sat Jan 14, 2017 8:07 pm

Client certificates issued by StartCom Class 1 Client CA not trusted/ working with Apple IOS 10

Postby florian@figula.de » Sat Jan 14, 2017 8:16 pm

Hi all,

I am not able to use Class 1 client certificates issued by StartCom Class 1 Client CA with my iPhone running IOS 10 anymore. I think the problem is that Apple is not trust this CA anymore or StartCom is using a new CA for this certificates since a specific date. The problem main problem is, the cell won't use the untrusted certificate for e-mail signatures or encryption.

https://support.apple.com/en-us/HT204132

jakumpe@kumpes.com
Posts: 5
Joined: Thu Dec 15, 2016 2:01 am

Re: Client certificates issued by StartCom Class 1 Client CA not trusted/ working with Apple IOS 10

Postby jakumpe@kumpes.com » Sun Jan 15, 2017 12:06 am

Welcome to the club. StartCom has been dis-trusted by Apple, Mozilla, and Google. They say they are working on a resolution but they have been since October. See this post viewtopic.php?f=16&t=622

mail@till-steinbach.de
Posts: 1
Joined: Sat Jan 28, 2017 4:55 pm

Re: Client certificates issued by StartCom Class 1 Client CA not trusted/ working with Apple IOS 10

Postby mail@till-steinbach.de » Sat Jan 28, 2017 4:59 pm

Same here.

Does this apply to paid certificates as well, or only the free ones? My valid certificate will expire in about two weeks and I need a solution then.

trev@acrovoice.ca
Posts: 6
Joined: Mon Dec 19, 2016 9:44 pm

Re: Client certificates issued by StartCom Class 1 Client CA not trusted/ working with Apple IOS 10

Postby trev@acrovoice.ca » Wed Feb 01, 2017 5:40 pm

Paid as well. For the fun of it, I had an EV certificate issued but it's not trusted either.


Return to “Client Certificate”